Registrar Transfer in Progress: Temporary Domain Email Disruptions

Incident Report for Hermida Enterprise Solutions

Resolved

This incident has been resolved.
Posted Jul 27, 2025 - 03:32 UTC

Identified

We are currently performing a domain registrar update to ensure long-term stability, security, and reliability of our core systems.

As part of this process, access to our administrative email address (**sales@hermidaenterprisesolutions.com**) is temporarily limited. This may cause minor delays in workflows that rely on domain-level email verification or internal account validation processes.

**Please note:**
- No customer data is affected
- Client-facing platforms (HTUSA+, Fintra+, Omega V3, etc.) remain fully operational
- Support channels and product services are not impacted

We’ve escalated the situation to Microsoft support and are actively working with registrar partners to finalize the transition.

We appreciate your patience as we work to complete this infrastructure update.

**Next update:**
We will provide another update within 48-72 hours or sooner as new information becomes available.
Posted Jul 25, 2025 - 23:00 UTC
This incident affected: MYHTUSA.com, FintraPlus+, and Hermida Enterprise Solutions.